Bavarian-Board.co.uk - BMW Owners Discussion Forum Homepage
Forum Home Forum Home > Technical & Model Specific Forums > BMW 6 Series
  New Posts New Posts RSS Feed - Eratic engine speed
  FAQ FAQ  Forum Search   Register Register  Login Login

Eratic engine speed

 Post Reply Post Reply
Author
Message
Howard View Drop Down
Moderator Group
Moderator Group
Avatar
Did I say thaaaat?

Joined: 14-October-2002
Location: United Kingdom
Status: Offline
Points: 735
Post Options Post Options   Thanks (0) Thanks(0)   Quote Howard Quote  Post ReplyReply Direct Link To This Post Topic: Eratic engine speed
    Posted: 24-March-2014 at 14:38
My 635 has started revving up from 1500 revs to 2500 and back down again, making it almost un-driveable except in 2nd and with a foot poised on the brake.
Changing the startup temperature sensor had some effect, but it was only short term. Now it revs between 2000 and 2500 RPM.
Has anyone else had a similar problem, and if so how did they solve it.
1963 700 LS
1988 635 CSi
1990 M635 CSi no longer!
2001 E38 728i Individual


http://www.tyneships.co.uk
Back to Top
Sponsored Links


Back to Top
Andrew Rolland View Drop Down
Moderator Group
Moderator Group
Avatar
Go away rain

Joined: 19-August-2004
Location: Scotland
Status: Offline
Points: 6579
Post Options Post Options   Thanks (0) Thanks(0)   Quote Andrew Rolland Quote  Post ReplyReply Direct Link To This Post Posted: 24-March-2014 at 15:23
Idle control valve bunged up?
 
Clean it out with Wynns Carb and fuel injector cleaner, dissovles oily gunk in seconds.
 
Or
 
Coil.
 
I had an erratic idle problem on my Mini, turned out to be the ignition coil.
 
Or
 
Air leak from egr system or inlet manifold joints etc.
Be exclusive and drive a Petrol 5 Series!

Current
'13 62 F10 535i MSport Auto

Previous
'04 04 E60 545i SE Auto
'03 53 E60 545i SE Auto (Stolen)
'98 S E39 523i SE Auto
Back to Top
Indian View Drop Down
Groupie
Groupie


Joined: 29-March-2009
Status: Offline
Points: 78
Post Options Post Options   Thanks (0) Thanks(0)   Quote Indian Quote  Post ReplyReply Direct Link To This Post Posted: 25-March-2014 at 09:20
I had similar problem with my E23.
Recon AFM and change all the vacuum and intake hoses solved the problem.
Starts on the button even after sitting in the garage for 2 1/2 months
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.281 seconds.