Bavarian-Board.co.uk - BMW Owners Discussion Forum Homepage
Forum Home Forum Home > Technical & Model Specific Forums > BMW 5 Series
  New Posts New Posts RSS Feed - E60 heater blower
  FAQ FAQ  Forum Search   Register Register  Login Login

E60 heater blower

 Post Reply Post Reply
Author
Message
bodyguarduk View Drop Down
Groupie
Groupie


Joined: 12-January-2006
Location: harrogate
Status: Offline
Points: 61
Post Options Post Options   Thanks (0) Thanks(0)   Quote bodyguarduk Quote  Post ReplyReply Direct Link To This Post Topic: E60 heater blower
    Posted: 13-March-2016 at 17:39
Ok had my BMW e60 525d m sport about 3 weeks when I bought it the battery was flat so a lot of things didn't work properly such as heater wouldn't go above 2nd speed and rear de mist wouldn't work. I decided to just replace the battery with a new one. Ok since doing this everything was great,then the fan stopped working for a few days then started again when I hit a pot hole but speed was kind of sluggish on full. The other day it stopped again then started after a jolt as I hit another pot hole but when I went out again nothing and has been off since. I replaced the resister on the motor today with a new one and all seemed good , I left the switch on number 2 when I locked the car. Just gone out to the car and no heater again ... could it be the blower motor that's gone or something else ? Help needed going insane
Back to Top
Sponsored Links


Back to Top
Andrew Rolland View Drop Down
Moderator Group
Moderator Group
Avatar
Go away rain

Joined: 19-August-2004
Location: Scotland
Status: Offline
Points: 6578
Post Options Post Options   Thanks (0) Thanks(0)   Quote Andrew Rolland Quote  Post ReplyReply Direct Link To This Post Posted: 15-March-2016 at 08:09
Did you register the new battery to the car?

A replacement battery needs to be programmed into the car so that it knows the battery now on board is new and thus has a different charge/discharge cycle.

After that I would get your codes read to see if there is anything else amiss.
Be exclusive and drive a Petrol 5 Series!

Current
'13 62 F10 535i MSport Auto

Previous
'04 04 E60 545i SE Auto
'03 53 E60 545i SE Auto (Stolen)
'98 S E39 523i SE Auto
Back to Top
bodyguarduk View Drop Down
Groupie
Groupie


Joined: 12-January-2006
Location: harrogate
Status: Offline
Points: 61
Post Options Post Options   Thanks (0) Thanks(0)   Quote bodyguarduk Quote  Post ReplyReply Direct Link To This Post Posted: 15-March-2016 at 11:53
Had it on code reader no faults all is clear. It's definitely a heater problem as it works then totally stops working. If it was the battery I would get a high voltage use warning wouldn't I ? Checked about registering battery and was told its only if you change from wet to dry cell . Plus everything else works heated rear screen ect.
Back to Top
bodyguarduk View Drop Down
Groupie
Groupie


Joined: 12-January-2006
Location: harrogate
Status: Offline
Points: 61
Post Options Post Options   Thanks (0) Thanks(0)   Quote bodyguarduk Quote  Post ReplyReply Direct Link To This Post Posted: 19-March-2016 at 18:20
Blower motor changed and all looking good, even get motor working away quietly on 0 speed then off totally when off button pressed which didn't happen with old motor in. Is this what should happen ???
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down



This page was generated in 0.141 seconds.